2014 R-Spec Alignment/Drifting Issue - Hyundai Genesis Forum
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 11-25-2019, 09:38 PM Thread Starter
Junior Member
 
Join Date: Nov 2019
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
2014 R-Spec Alignment/Drifting Issue

2014 Genesis R-Spec, 45K miles. Up to now, a perfect car. New tires 2K back, everything was fine for 1000 miles. Then Spousal Unit reports hitting a pothole...hard. Related? Since then, car has a nagging drift to the right. It has been aligned 3 times; twice at dealer. Independent shop aligned it first, but when this did not
fix it, they suggested control arm bushings might be bad and recommended taking it to dealer. So it has been to the dealer twice. "Bushings and everything else fine". "Twice fixed" but no change in drift. "Fixes" amounted to alignments. Same dealer aligned it twice within 2 weeks and could not explain how it was out of alignment again. Dealer has had the care for over a week this time and haven't had an update.

Anybody else had similar issues?
Dermodad is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 12-01-2019, 09:39 PM Thread Starter
Junior Member
 
Join Date: Nov 2019
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
(Thread Starter)
Got it back from dealer again, this time after a "road force balance". I can't say anything is fixed. But I will say the problem seems intermittent. Or I am intermittently crazy. Equal odds.
Dermodad is offline  
Sponsored Links
Advertisement
 
Reply

User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome